【WordPress】カスタム投稿で「Protect the Children!」を有効にする

親ページにパスワードを設定すると子ページも同じパスワードが自動的に設定されるプラグイン「Protect the Children!」があります。

固定ページなどでは、プラグインを有効化すると設定すること必要もなく有効化されます。しかし、カスタム投稿には、設定項目(Password Protect all children)が表示されませんでした。

WordPress公式プラグインのSupportを見てみると同じような質問があり、回答もありました。

カスタム投稿の設定で以下の設定が必要とのことでした。

  • hierarchicalが有効になっている
  • supportsパラメーターのcustom-fieldsがサポートされている

参考